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Overview 
Welcome to your new Custom Sound Device Makers Kit! We’re thrilled to have you as 
a customer and thank you for your support. We hope you have as much fun using 
your Maker’s Kit as we had developing it. 
In this manual, we’ve included everything you need to integrate your Maker’s Kit into 
your next project, but should you have any questions or need assistance, please don’t 
hesitate to reach out at contact@kytechindustries.com. 
 
 

1. Specifications 
Battery Input Voltage 6.5 – 15V 
Trigger Input Voltage 3.3 – 13 V 
Low Voltage Cutoff 2S 6.1 V 
Low Voltage Cutoff 3S 9.1 V 
Amplifier Gain (on audio signal) 20dB 
Max Amplifier Power 50 Watts 
Idle Power Consumption 0.5 Watt 
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Figure 1 - PCB Dimensions (millimetres) 

2. Basic Operation 
Your Custom Sound Device (CSD) Maker’s Kit (MK) comes ready to go and wired up in 
standard form (see section 4 for alternate wiring options) and can be used right away. 
We’ve included a micro SD with a few sounds to get you started.  
 
 



 

 
Figure 2 - Main PCB Inputs and Outputs 

 
 
 
 
 

2.1.  Powerup 

On powerup, your CSD will make some tones indicating the status of the SD card: 
 
Tone Sequence State Indication 

3 beeps, ascending tones Success! SD card is installed, and sound files are 
present 
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(1) Trigger Sensor 5V supply 
(2) Trigger Input 
(3) Trigger 0V 
(4) Micro SD Card Mount 
(5) 3.5mm Audio Jack Output 
(6) Battery Positive 
 

(7) Battery Negative 
(8) Voltage Cut-Off Selection Switch 
(9) Speaker Negative 
(10) Speaker Positive 
(11) Volume Adjustment Pot 
(12) Mode Button 



 

3 beeps, descending 
tones 

Fault: SD card is not installed. Playback will default 
to a single tone 

4 beeps, descending 
tones, last two beeps at 
same tone. 

Fault: SD card is installed, but no sound files are 
detected. Playback will default to a single tone 

 
 

2.2.  Mode Selection 

To cycle through the playback modes, single tap the Mode Button (Figure 2, 12). 
While cycling through the modes, the device will play a number of beeps indicating 
the selected mode number. 
 

2.3.  Modes 

 
Mode Name Description 

1 Random Playback Random audio file playback with each triggering of 
the device. 

2 Sequential Playback Audio files are sorted alphabetically, with playback 
incrementing through the files with each triggering 
of the device. 

3 Burst See below Section 2.3.1 
 

4 Track Select Each triggering of the device plays the selected 
audio file. To select a file, double-tap the Mode 
Button while the device is in Mode 4 to cycle 
through the available options. The device will play a 
preview (3 seconds) of the currently selected file. 

 

2.3.1. Burst Mode  

Burst Mode allows you to playback a specific audio file when burst-fire is 
detected. For example – you want to the device to play the national anthem (or 
The Imperial March) while you’ve got the trigger pinned laying down some 
supressing fire.  



 

 
Burst Mode Track Selection 
Burst Mode automatically plays the first audio track on the SD card. Tracks on the 
SD card are sorted in alphabetical order, so to set a specific burst playback track, 
you must name the file so that it is indexed first on the SD card. Adding “AA” to 
the start of the file name is the best way to achieve this. Example: 

AANATIONALANTHEM.wav 
For full details on correct file formatting, please see Section 3. 
 
The burst mode parameters can be adjusted: 
 

Parameter Description 
Shot-Count The number of shots required to trigger burst mode 

for the given checking time 
Burst-Time-Ms The period of time which the shot count must be 

achieved within to trigger burst mode 
Time-Out-Ms The burst playback will automatically stop if no 

new shots are detected within the timeout period 
after the last recorded shot. 

 
The default Burst parameters are: 
Shot-Count: 10 
Burst-Time-Ms: 3000 milliseconds (3 seconds) 
Time-Out-Ms: 3000 milliseconds (3 seconds) 
 
When in default, the user must shoot 10 shots in less than 3 seconds to trigger 
the mode. If the user takes too long to fire the required shots, the timing and 
counter resets after 3 seconds. Once the burst audio starts playback, if no shots 
are detected within 3 seconds, playback will stop. 

To assign custom Burst Mode parameters, you must include a text file on the SD 
card named settings.txt. The format of the text file must be: 

# Configuration settings 
Debug:0 
Shot-Count:10 
Burst-Time-Ms:3000 



 

Time-Out-Ms:3000 
 

 

Figure 3 - Example settings.txt file with some long time values 

 

2.4.  Volume Adjustment 

The volume can be adjusted by turning the Volume Adjustment Pot (Figure 2, 11). 
• To increase the volume, turn the pot clockwise. 
• To reduce the volume, turn the pot anti-clockwise. 
Generally, you’ll want this set to maximum, and use audio file adjustments for the 
desired volumes on a per-file basis.  

 

2.5.  Low Voltage-Cutoff (LVC) Selection 

Use the LVC Selection Switch (Figure 2, 8) to set the low voltage cutoff according to 
your battery type. The switch position (2S or 3S) is labelled on the PCB. 
• For a 2S LiPo, set the switch to 2S. 
• For a 3S LiPo, set the switch to 3S. 
 

 2S 3S 



 

Low Battery Warning Voltage 7.0V 9.5V 
LVC Voltage 6.5V 9.0V 

 
The device will emit a low battery warning, 3 low frequency beeps, when voltage 
levels are approaching the LVC Voltage. The low battery warning will repeat every 60 
seconds until the LVC Voltage is reached where the device will shut down and 
remain off to protect the battery.  
If the LVC Voltage is violated, the device may experience brown out (turning off and 
on again), unstable operation, or will power down completely until a charged battery 
is connected.  
We advise switching to a charged battery as soon as the low battery warning is 
heard.  

 

2.6. External Audio Output 

Audio playback can be routed to an external powered speaker through the 3.5mm 
Audio Jack Output (Figure 2, 5). If a speaker is also soldered to the PCB, audio will be 
simultaneously output through both the onboard and external speakers. 
 
 
 
 
 
 
 
 
 
 

 

3. Installing Audio Files 
The CSD uses a Micro SD card to read sound files. To add a sound file, simply drag and 
drop the .wav file from your computer onto the SD card, then insert the card into the 



 

Micro SD port on the PCB (Figure 2, 4). To work with the CSD, sound files must be 
formatted as described in the following sections. 

3.1.  Sound File Format/Properties 

For the device the recognize and process an audio file, it must have the following 
properties: 
 

File Type .wav 
Audio Signal Type Mono 
Sample Rate 44.1 kHz 
Encoding Signed 16-bit PCM 
File Name All caps, no spaces or special characters.  

Example: MK416.wav 
 

Files installed on the SD card are sorted alphabetically – you can manipulate the 
order of sound files by adding a leading designator to the file name: 

  
AMK416.wav 

  BSUPRESSEDRIFLE.wav 
  CAR15.wav 
 
 
 
 
 
 
 
 
 

3.2.  Creating/Editing Sound Files with Audacity 

You can edit and create your own sound files using the free Audacity audio editing 
software. 
 
Download: https://www.audacityteam.org/ 
 

https://www.audacityteam.org/


 

To create a sound file: 
1. Download, install and launch Audacity. 
2. Go to File > Import > Audio, and select the audio file you want to edit. 
 

 
 



 

 
 
 
3. In the above example, we have a recording of multiple shots of an AK47, which 

we want to trim down to a single shot. 
4. First, we will split the track to mono. Click the 3 dots above the Solo button, then 

select “Split Stereo to Mono”. 
 

 
 

5. Click the X on the bottom track to delete it. 
 



 

 
 
6. Next, do a coarse trim of the track by hovering over the far-right edge of the track, 

then click and drag to shorten the track to roughly the desired length. 
 

 
7. To fine trim the track: 

a. With the mouse in the track area, hold Ctrl and use the mouse wheel to 
zoom in on the track. 

b. Left mouse-click and drag to select the fine trim area – we want as little 
dead-zone on either side of the soundwave as possible. 

c. Once highlighted, click the Play button to preview the selected area and 
ensure it captures the desired sound. 

Click and drag 



 

 
 

d. Go to Edit > Remove Special > Trim Audio. 
 

 
 
8. Hover over the top bar of the audio track and left-click to select the whole track. 
9. Go to Tracks > Resample... 
10. Set the Sample Rate to 44100. 
 



 

 
 
11. Hover over the top bar of the audio track and left-click to select the whole track. 
12. Go to Effect > Volume and Compression > Normalize… 
13. Set Normalize peak amplitude to -0.99 and click apply. 
 

 



 

14. Export the edited track: 
a. Go to File > Export Audio. 
b. Click Export to Computer. 
c. Name the file as per the file naming convention: all caps, no spaces or 

special characters. Example: MK416.wav 
d. Select your export location. 
e. Confirm “Mono” is selected. 
f. Confirm the Sample Rate is 44100 Hz. 
g. Confirm the encoding is Signed 16-bit PCM. 
h. Click Export. 

 

 
 
 
 
 



 

 
 
Your sound file is now ready for use!  
 
General tips for audio files:   
• they should be short and start loud to give the best effect with automatic fire 

rates.  
• Aim for sound files around 0.1 to 1.0 seconds long.  
• Avoid long trailing reverb/echo sounds or low volume crackle at the end of the 

tracks.  
• If your soundtrack has a long wind-up before the bulk of the audio is heard, then 

you should choose to fire in semi-auto or have a slow fire rate (with MOSFET 
controlled rate of fire) so that you get the best outcome. Retriggering the sound 
file before you’ve reached the main part of the sound effect means until the very 
last shot you will not hear it properly. Experiment with sound file lengths and 
fire rates. 

  



 

4. Wiring 
Your Custom Sound Device comes pre-wired in the default configuration with the 
Sensor Cable, Battery Cable, and Speaker soldered to the PCB. Adapting the 
configuration to suit your custom setup is encouraged and will require some basic 
soldering work if you wish to extend or replace the cables. 

4.1.  Triggering System 

The Custom Sound Device can be triggered either using the supplied Sensor Unit, or 
by an external voltage source between 5V and 13V. 

4.1.1. Using Included Sensor 

To use the included Sensor Unit, simply connect the Sensor Cable to the Sensor 
Unit. 
 
Cable requirements for custom made cables: 
- Wire: 24 AWG minimum 
- Sensor Connector: 

o CONNECTOR: JST part number XHP-3  
o CRIMPS: JST part number SXH-001T-P0.6 

 

4.1.2. Using Alternate Trigger Method 

The Main PCB can be wired directly to your AEG’s trigger or microswitch/MOSFET 
fire control unit for shot triggering. Note that this wiring configuration only 
supports semi-automatic firing mode. If you pull and hold the trigger down, only 
one shot will trigger for each pull of the trigger (needs a transition of voltage).  

 



 

 
Figure 4 - Wiring Directly to AEG Trigger 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

5. Sensor Unit  

 
 

5.1.  Overview + Specs 

The included Sensor Unit is plug-and-play with the Makers Kit using the supplied 
Sensor Cable. The sensor utilises transmitting and receiving UV diodes to trigger the 
CSD when a projectile passes through the barrel of the sensor. 
The Sensor Unit also doubles as a tracer unit, compatible with green tracer BB’s. 
Please note that the tracer functionality will not work with red tracer BB’s. 

 
Input Voltage 5V 
Output Voltage (signal) 5V 
Connector (sensor side) JST XH Series 

Part Number: S3B-XH-SM4-TB 
Connector (cable side) JST XH Series 

Part Number: XHP-3 
 
 
 
 
 
 
 
 



 

5.2.  Disassembly 

 
Figure 5 - Sensor Disassembly 

To disassemble the Sensor Unit: 
1. Disconnect and remove the sensor unit from your device. 
2. Remove the Sensor Unit Outer Housing by unscrewing it clockwise. 
3. Remove the 2 x M2 screws securing the Upper PCB to the Sensor Unit 

Inner Part. 
4. Carefully wiggle the upper and lower PCB’s to separate them from the 

Inner Part. 
5. To reassemble the Sensor Unit, repeat steps 1 through 4 in reverse order, 

taking care to ensure that the header pins connecting the upper and 
lower PCB’s are aligned and securely seated. 

Upper PCB Screws 

Header Pins 

Upper PCB 

Lower PCB 



 

5.3. Wiring 

 
Figure 6 - Sensor Wiring 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

0V 

5V (input) 

5V (sensor output) 



 

6. Troubleshooting 
Concern Diagnosis Steps 

Device not powering on - Check battery is sufficiently charged 
- Confirm LVC switch is set correctly 
- Check physical connections and connectors 

Device not playing sound 
when triggered 

- Check sensor connector is properly seated 
- Check sensor cable connections at Main PCB 
- Check SD is installed 
- Check volume is turned up 
- Check sound files are correctly formatted 
- Test using the supplied SD and files 
- Check sensor is triggering: 

6. Unscrew sensor outer housing  
7. With the device powered on, insert a q-tip into 

the sensor barrel – a blue UV light will flash if 
the sensor is triggered 

Device restarts when 
triggered 

- Generally caused by battery voltage dropping 
below the low voltage cutoff upon playing the 
sound. 

- If you are experiencing device restarts before the 
low battery warning is sounded, we recommend 
either: 
a. Lower the volume of the device 
b. Lower the volume of the audio track 
c. Use a freshly charged battery 
d. Power the device using a 3S 11.1V battery 

 

For maximum volume and loudness, we recommend 
using a 3S 11.1V battery. 

Note that some audio files are “louder” than others and 
will cause a more significant load and resulting voltage 
drop when triggered. We recommend tuning your audio 
file volume along with the device volume to achieve 
optimal performance for your application. 

 



 

If you are still experiencing concerns with your device, please get in touch at 
contact@kytechindustries.com. To help us assist you, please provide a debug file as per 
the instructions below. 
 
To create a debug file: 

1. Create a .txt file called settings.txt 
2. Populate settings.txt with debug set to 1 as below. Other settings can just be the 

defaults shown: 
 

# Configuration settings 
Debug:1 
Shot-Count:10 
Burst-Time-Ms:3000 
Time-Out-Ms:3000 
 

3. Put settings.txt on your micro SD card and insert it in the CSD. 
4. Replicate the concern you are experiencing with the device. 
5. Remove the SD and access it with your computer. 
6. Open the SD and save the file DEBUGLOG.txt somewhere onto you computer.  
7. Send the file to us for review. 

 

 
Figure 7: Example settings.txt file content with debug enabled 
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